VCOM:VectorWorks:ISDK::ClassIDToName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets className to the name of the class with the specified ID number. Valid class ID numbers range from one up to MaxClassID(), though not necessarily all numbers in that range will be defined classes. If classID does not map to a defined class, class name is set to the empty string.

virtual void ClassIDToName(
InternalIndex classID,
InternalName className)

Parameters

InternalIndex classID No information available.
InternalName className No information available.

Version

Availability: from Vectorworks 2009