VCOM:VectorWorks:ISDK::Centroid3D

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns the center of gravity of a 3D object. The function returns true if the values were found.

virtual bool Centroid3D(
MCObjectHandle h,
double_gs &xCG,
double_gs &yCG,
double_gs &zCG)

Parameters

MCObjectHandle h No information available.
double_gs &xCG No information available.
double_gs &yCG No information available.
double_gs &zCG No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009