VCOM:VectorWorks:ISDK::CStringEqual

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns true if the C strings cStr1 and cStr2 are equal, false if they are not. The bit-flags compareFlags must be from EStringCompare, which currently has: kDefaultCompare, kIncludeCase, kIgnoreCase. (kDefaultCompare is what VW uses internally to compare names - currently it is equal to kIgnoreCase.)

virtual CBbool CStringEqual(
const TXString& cStr1,
const TXString& cStr2,
const short compareFlags)

Parameters

constTXString& cStr1 No information available.
constTXString& cStr2 No information available.
constshort compareFlags No information available.

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009