VCOM:VectorWorks:ISDK::AppendRoofEdge

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Create a vertex of the roof. Vertex is appended to the end of the list of vertices. Vertices define the outline of the roof. Vertices must progress in a counter clock wise direction, when viewed from a top view, otherwise the roof cannot be built.


edgePt: Coordinate point for this edge

slope: pitch of this roof edge

projection: eave overhang

eaveHeight: eave height

virtual bool AppendRoofEdge(
MCObjectHandle object,
const WorldPt& edgePt,
double_param slope,
WorldCoord projection,
WorldCoord eaveHeight)

Parameters

MCObjectHandle object No information available.
constWorldPt& edgePt No information available.
double_param slope No information available.
WorldCoord projection No information available.
WorldCoord eaveHeight No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009