VCOM:VectorWorks:ISDK::AlertQuestion

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Displays a dialog that alerts the user to a condition or situation that requires the user's decision and input before preceeding, such as an impending action with potentially destructive or irreversible consequencies. Specify a category and an item to show an optional 'Always do the selected action' checkbox.

virtual short AlertQuestion(
const TXString& question,
const TXString& advice = "",
short defaultButton = 0,
const TXString& OKOverrideText = "",
const TXString& cancelOverrideText = "",
const TXString& customButtonAText = "",
const TXString& customButtonBText = "",
const TXString& category = "",
const TXString& item = "",
const TXString& checkboxOverideText = "")

Parameters

const TXString& question Question text that appears in the dialog.
const TXString& advice Advice text that appears in the dialog.
short defaultButton Default button that is selected in the dialog.
const TXString& OKOverrideText Text that should appear on the OK button.
const TXString& cancelOverrideText Text that should appear on the CANCEL button.
const TXString& customButtonAText First additional button text. If empty no button appears.
const TXString& customButtonBText Second additional button text. If empty no button appears.
const TXString& category Category for the saved settings that the answer will be stored.
const TXString& item Item for the category of the saved settings that the answer will be stored.
const TXString& checkboxOverideText Override text for the check button.

Return Value

Returns 1 for the OK button; 0 for the CANCEL button; 2 for the custom button A; and 3 for the custom button B;

Version

Availability: from Vectorworks 2009