VCOM:VectorWorks:ISDK::AddTextFromBuffer

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This is identical to GS_AddText except it takes the text to be added from a pointer rather than a Mac-specific Handle. This function provides the only way to add text to a text block from a native Windows external. A result of true indicates success. A result of false indicates failure due to low memory or invalid parameters.

virtual bool AddTextFromBuffer(
MCObjectHandle textBlock,
long beforeChar,
void* buffer,
long bufferSize)

Parameters

MCObjectHandle textBlock No information available.
long beforeChar No information available.
void* buffer No information available.
long bufferSize No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009