VCOM:VectorWorks:ISDK::AddChoice

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Add strItemText to a layout manager list box or pull down menu. The text item is added at position nItemIdex. This is a zero based index for the list of items.

This call should only be used inside of an event handler callback function.


For the multicolumn list box, items in different columns must be separated by tab characters. I.e., use this function to set a whole line at a time, with columns separated by tab characters. All tab stops must have been set before calling this function.

virtual void AddChoice(
long dialogID,
long itemID,
const TXString& strItemText,
short nItemIndex)

Parameters

long dialogID No information available.
long itemID No information available.
constTXString& strItemText No information available.
short nItemIndex No information available.

Version

Availability: from Vectorworks 2009