VCOM:VectorWorks:ISDK::AddBeforeSwapObject

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Use this callback before you delete an object in your routine. The object is stored in the undo table and is re-inserted into the drawing when undo is selected. Only applicable after a SetUndoMethod(cbp, kUndoSwapObjects) or a SetUndoMethod(cbp, kUndoReplaceSelection) call has been made. After this call is issued, the object should be deleted using the call GS_DeleteObject(h, true), with the true indicating that undo is in effect for this object. Passing a nil handle creates undo primitives for all selected objects.

virtual bool AddBeforeSwapObject(
MCObjectHandle h)

Parameters

MCObjectHandle h No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009