VCOM:VectorWorks:ISDK

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Provides fundamental functionality of VectorWorks SDK.

Members

Attributes (Class)

GetClColor GetClFillPat GetClLineWeight GetClMarker
GetClPenPat GetClUseGraphic GetClVisibility GetClassBeginningMarker
GetClassEndMarker GetVPClassFillStyle SetClColor SetClFillPat
SetClLineWeight SetClMarker SetClPenPat SetClUseGraphic
SetClVisibility SetClassBeginningMarker SetClassEndMarker VPClassHasOverride

Attributes (Default)

DeleteAllDLComponents DeleteDLComponent GetDLComponentClass
GetDLComponentFill GetDLComponentFillColors GetDLComponentName
GetDLComponentPenColors GetDLComponentPenStyles GetDLComponentPenWeights
GetDLComponentUseFillClassAttr GetDLComponentUsePenClassAttr GetDLComponentWidth
GetDLControlOffset GetDLOptions GetDLSeparation
GetDefaultArrowByClass GetDefaultArrowHeads GetDefaultArrowHeadsN
GetDefaultBeginningMarker GetDefaultClass GetDefaultColors
GetDefaultEndMarker GetDefaultFColorsByClass GetDefaultFPatByClass
GetDefaultFillPat GetDefaultHatch GetDefaultLWByClass
GetDefaultLineWeight GetDefaultPColorsByClass GetDefaultPPatByClass
GetDefaultPenPat GetDocumentDefaultSketchStyle GetNumberOfDLComponents
GetObjectInternalIndex GetProgramVariable GetWallPrefStyle
GetWallStyle InsertNewDLComponent SetDLComponentClass
SetDLComponentFill SetDLComponentFillColors SetDLComponentName
SetDLComponentPenColors SetDLComponentPenStyles SetDLComponentPenWeights
SetDLComponentUseFillClassAttr SetDLComponentUsePenClassAttr SetDLComponentWidth
SetDLControlOffset SetDLOptions SetDLSeparation
SetDefaultArrowByClass SetDefaultArrowHeads SetDefaultArrowHeadsN
SetDefaultBeginningMarker SetDefaultClass SetDefaultColors
SetDefaultEndMarker SetDefaultFColorsByClass SetDefaultFPatByClass
SetDefaultFillPat SetDefaultHatch SetDefaultLWByClass
SetDefaultLineWeight SetDefaultPColorsByClass SetDefaultPPatByClass
SetDefaultPenPat SetDefaultWallThickness SetDocumentDefaultSketchStyle
SetProgramVariable SetWallPrefStyle WrapGetDefaultWallThickness

Attributes (Geometric)

Add3DVertex AddVertex CalcAreaN CalcPerimN
CalcSurfaceArea CalcVolume Centroid3D CountVertices
CreateSkylight DeleteVertex ForEach3DPointInObject ForEachPolyEdge
Get3DVertex GetArcInfoN GetBatAttributes GetControlVertex
GetDormerAttributes GetEndPoints GetEntityMatrix GetExtrudeValues
GetGableAttributes GetHipAttributes GetLocus3DPosition GetLocusPosition
GetMarkerPolys GetNumRoofElements GetObjectBoundingBoxVerts GetObjectBounds
GetObjectCube GetPolyDirection GetPolyShapeClose GetQArcQuadrant
GetRRectDiameters GetRoofAttributes GetRoofElementType GetShedAttributes
GetSkylight GetSweepAnglesN GetTrapeziumAttributes GetVertex
Insert3DVertex InsertVertex Moments3D NurbsCurveEvaluatePoint
NurbsCurveGetNumPieces NurbsCurveType NurbsDegree NurbsDelVertex
NurbsGetNumPts NurbsGetPt3D NurbsGetWeight NurbsKnot
NurbsNumKnots NurbsSetKnot NurbsSetPt3D NurbsSetWeight
NurbsSurfaceEvaluatePoint ObjArea ObjSurfaceArea ObjVolume
Products3D RemoveRoofElement Set3DVertex SetArcAnglesN
SetBatAttributes SetDormerAttributes SetDormerThick SetEndPoints
SetEntityMatrix SetExtrudeValues SetGableAttributes SetHipAttributes
SetLocus3DPosition SetLocusPosition SetObjectBounds SetPolyShapeClose
SetQArcQuadrant SetRRectDiameters SetRoofAccessoriesParameters SetRoofAttributes
SetShedAttributes SetSkylight SetSweepAnglesN SetSweepScrew
SetTrapeziumAttributes SetVertex WrapGetSweepScrew

Attributes (Graphic)

CreateCircularDimension GetArrowByClass GetArrowHeads GetArrowHeadsN
GetColor GetDefaultOpacity GetDefaultOpacityByClass GetFColorsByClass
GetFPatByClass GetFillIAxisEndPoint GetFillJAxisEndPoint GetFillOriginPoint
GetFillPat GetFillPoints GetLWByClass GetLineWeight
GetLineWeightDisplayMM GetLineWeightDisplayPt GetMarker GetObjBeginningMarker
GetObjEndMarker GetOpacity GetOpacityByClass GetPColorsByClass
GetPPatByClass GetPenPat GetVertexVis SetArrowByClass
SetArrowHeads SetArrowHeadsN SetColor SetDefaultOpacity
SetDefaultOpacityByClass SetFColorsByClass SetFPatByClass SetFillIAxisEndPoint
SetFillJAxisEndPoint SetFillOriginPoint SetFillPat SetLWByClass
SetLineWeight SetLineWeightDisplayMM SetLineWeightDisplayPt SetObjBeginningMarker
SetObjEndMarker SetOpacity SetOpacityByClass SetPColorsByClass
SetPPatByClass SetPenPat SetVertexVis

Attributes (System)

GetDXFColorToLineWeight GetDefinition GetNamedObject GetObjectClass
GetObjectName GetObjectType GetSymbolDefinitionIcon GetSymbolDefinitionType
IsLocked IsSelected IsVisible LockObject
SelectObject SetDXFColorToLineWeight SetObjectClass SetObjectName
SetSymbolDefinitionIcon SetVisibility

Auxiliary and Data Objects

AttachAuxObject DeleteAuxObject FindAuxObject FindDataObject
FirstAuxObject GetDataTag GetPluginType IsPluginFormat
NewDataObject NextAuxObject NextDataObject RemoveAuxObject
TaggedDataCreate TaggedDataGet TaggedDataGetNumElements TaggedDataRemoveContainer
TaggedDataRemoveTag TaggedDataSet

Coordinate Transformation

CoordLengthToPageLengthN CoordLengthToPageLengthN CoordLengthToPagePoints CoordLengthToPixelLength
CoordLengthToUnitsLengthN CoordLengthToUnitsLengthN CoordToDimString CreateOvalN
DimStringToCoord FPCoordLengthToPageLength FPCoordLengthToUnitsLength ModelPt2DToScreenPt
ModelVecToScreenVec PageLengthToFPCoordLength PagePointsToCoordLength PixelLengthToCoordLength
ScreenPtToModelPt2D ScreenVecToModelVec UnitsLengthToFPCoordLength WorldCoordsPerDrawingUnit
WrapPageLengthToCoordLengthN WrapUnitsLengthToCoordLengthN

Creation

AddSolid AppendRoofEdge Create3DPoly CreateAngleDimension
CreateArcN CreateBatDormer CreateChainDimension CreateCombineIntoSurface
CreateCone CreateContourCurves CreateCustomDimensionStandard CreateCustomObject
CreateCustomObjectByMatrix CreateCustomObjectDoubleClick CreateCustomObjectPath CreateExtrude
CreateExtrudeAlongPath CreateGableDormer CreateGroup CreateHemisphere
CreateHipDormer CreateImageProp CreateInterpolatedSurface CreateLayer
CreateLayerN CreateLightN CreateLine CreateLinearDimension
CreateLocus CreateLocus3D CreateLoftSurfaces CreateNurbsCurve
CreateNurbsSurface CreateOval CreatePolyshape CreateQArc
CreateRRectangle CreateRRectangleN CreateRectangle CreateRectangleN
CreateRoof CreateRoundWall CreateShedDormer CreateSlab
CreateSphere CreateStaticHatch CreateStaticHatchFromObject CreateSurfacefromCurvesNetwork
CreateSweepN CreateSymbolDefinition CreateSymbolFolder CreateTaperedExtrude
CreateTrapeziumDormer CreateViewport CreateWall DefineCustomObject
DuplicateSelection ExtendNurbsCurve ExtendNurbsSurface GenerateBezierApproximationFromPolygon
GroupSelection IntersectSolid PerformMultipleUnion PlaceSymbolByNameN
PlaceSymbolN RevolveWithRail Split2DObjectByLine SubtractSolid

Dialogs

AddChoice AddListBoxTabStop AdjustComponentPixelPos AlertCritical
AlertInform AlertQuestion AlignBottomEdge AlignLeftEdge
AlignRightEdge AreListBrowserColumnLinesEnabled AreListBrowserRadioColumnLinesEnabled ClearGradientSliderSegments
Confirm CreateCMYKColorSwatch CreateCenteredStaticText CreateCheckBox
CreateCheckBoxGroupBox CreateClassPullDownMenu CreateColorPopup CreateControl
CreateCustomControl CreateDesignLayerPullDownMenu CreateEditInteger CreateEditReal
CreateEditText CreateEnhancedPullDownMenu CreateGroupBox CreateIconPushButton
CreateImageControl CreateLayout CreateLineAttributePopup CreateLineStylePopup
CreateLineWeightPopup CreateListBox CreateListBoxN CreateListBrowser
CreateMarkerPopup CreatePatternPopup CreatePullDownMenu CreatePullDownMenuGroupBox
CreatePushButton CreateRadioButton CreateRadioButtonGroupBox CreateResizableLayout
CreateRightStaticText CreateSeparator CreateSheetLayerPullDownMenu CreateStandardIconControl
CreateStaticText CreateSwapControl CreateSwapPane CreateSymbolDisplayControl
CreateSymbolDisplayControlScaleByZoom CreateTabControl CreateTabPane CreateThreeStateCheckBox
CreateTreeControl DeleteAllItems DeleteAllListBrowserItems DeleteListBrowserColumn
DeleteListBrowserItem DeselectEditText DisplayColorPopup DisplaySwapPane
DisplayTabPane EnableItem EnableListBrowser EnableListBrowserClickAllDataChange
EnableListBrowserColumnLines EnableListBrowserColumnTracking EnableListBrowserDragAndDrop EnableListBrowserDropOnIndices
EnableListBrowserRadioColumnLines EnableListBrowserSingleLineSelection EnableListBrowserSorting EnableListBrowserUpdates
EnsureListBrowserItemIsVisible ExpandTreeControlItem FindListBrowserColumnDataItem FindListBrowserColumnItem
FormatTextDialog GetActiveEditItem GetActivePane GetBooleanItem
GetCMYKColor GetChoiceCount GetChoiceIndex GetChoiceText
GetColorButton GetColorChoice GetComponentRect GetComponentTextWidth
GetControlData GetCustomControlScrollArea GetEditInteger GetEditReal
GetGradientSliderData GetGradientSliderSelectedMarker GetIconPushButtonState GetImagePopupObject
GetImagePopupObjectItemIndex GetImagePopupSelectedItem GetItemText GetLBHeaderTextWidth
GetLayoutDialogPosition GetLayoutDialogSize GetLayoutFromRsrc GetLineAttributeData
GetLineStyleChoice GetLineWeightChoice GetListBrowserColumnDataItemInfo GetListBrowserColumnHeaderJust
GetListBrowserColumnHeaderToolTip GetListBrowserColumnOwnerDrawnType GetListBrowserColumnSortState GetListBrowserColumnWidth
GetListBrowserControlType GetListBrowserEditDisplayType GetListBrowserEventInfo GetListBrowserItemDashStyle
GetListBrowserItemData GetListBrowserItemDisplayType GetListBrowserItemFillBackColor GetListBrowserItemFillForeColor
GetListBrowserItemGradientOrImageRefNumber GetListBrowserItemInfo GetListBrowserItemPenBackColor GetListBrowserItemPenForeColor
GetListBrowserItemTextColor GetListBrowserItemTextJust GetListBrowserItemTextStyle GetListBrowserSortColumn
GetMarkerChoice GetMarkerPopupSelectedItem GetMultilineText GetNumGradientSliderSegments
GetNumImagePopupItems GetNumListBrowserColumnDataItems GetNumListBrowserColumns GetNumListBrowserItems
GetNumSelectedListBrowserItems GetPatternData GetSelChoiceIndex GetSelectedChoiceIndex
GetSelectionRange GetThreeStateCheckBoxState GetTreeControlItemData GetTreeControlSelectedItem
InsertGradientSliderSegment InsertImagePopupObjectItem InsertImagePopupResource InsertImagePopupSeparator
InsertListBrowserColumn InsertListBrowserColumnDataItem InsertListBrowserItem InsertProposedClassOrLayerItem
InsertTreeControlItem IsItemEnabled IsItemVisible IsListBrowserColumnTrackingEnabled
IsListBrowserItemSelected IsListBrowserSortingEnabled NotifyPullDownClicked OverrideControl
PostMinorNoteAlert PostMinorStopAlert PostNoteAlert PostStopAlert
RefreshItem RefreshListBrowser RemoveAllImagePopupItems RemoveAllListBrowserColumnDataItems
RemoveChoice RemoveEnhancedPullDownMenuItemRange RemoveGradientSliderSegment RemoveImagePopupItem
RemoveListBoxTabStop RemoveListBrowserColumnDataItem RemoveTreeControlItem RunLayoutDialog
SelectChoice SelectEditText SelectTreeControlItem SetBelowItem
SetBooleanItem SetCMYKColor SetColorButton SetColorChoice
SetComponentIndeterminate SetComponentSize SetControlData SetEdgeBinding
SetEditInteger SetEditReal SetFirstGroupItem SetFirstLayoutItem
SetFocusOnItem SetFocusOnListBrowser SetGradientSliderData SetGradientSliderSelectedMarker
SetHelpText SetIconPushButtonState SetImageControlHandle SetImageControlPath
SetImagePopupSelectedItem SetItemText SetItemToolTipText SetLayoutDialogPosition
SetLayoutDialogSize SetLayoutOption SetLineAttributeData SetLineStyleChoice
SetLineWeightChoice SetListBrowserColumnHeaderJust SetListBrowserColumnHeaderToolTip SetListBrowserColumnImage
SetListBrowserColumnOwnerDrawnType SetListBrowserColumnWidth SetListBrowserControlType SetListBrowserDragAndDropColumn
SetListBrowserEditDisplayType SetListBrowserItemDashStyle SetListBrowserItemData SetListBrowserItemDisplayType
SetListBrowserItemFillBackColor SetListBrowserItemFillForeColor SetListBrowserItemGradientOrImageRefNumber SetListBrowserItemInfo
SetListBrowserItemPenBackColor SetListBrowserItemPenForeColor SetListBrowserItemTextColor SetListBrowserItemTextJust
SetListBrowserItemTextStyle SetListBrowserItemUsingColumnDataItem SetListBrowserSelection SetListBrowserSortColumn
SetMarkerChoice SetMultilineText SetPatternData SetProportionalBinding
SetRightItem SetSelectionRange SetTextEditable SetThreeStateCheckBoxState
SetTreeControlItemData ShowEnhancedPullDownMenuGroupIcon ShowItem UpdateCustomControlScrollArea
UpdateSymbolDisplayControl UpdateSymbolDisplayControlScaleByZoom VerifyLayout

Document

AddClass AddDashPat AddGuidesClass ColorIndexToName
ColorIndexToRGB CopySymbol CreateGradient CreateHatch
CreateImageFromPaint CreatePaintFromImage CreateWallStyle DeleteClass
DeleteDashPat DeselectAll GetActiveSymbolDef GetClassVisibility
GetCurrentLayer GetCurrentView GetDashPat GetDimensionClassID
GetGradientData GetGradientMidpointPosition GetGradientSpotColor GetGradientSpotPosition
GetGridUnits GetHatchLevel GetLayerScaleN GetNamedLayer
GetNoneClassID GetNumDashPats GetNumGradientSegments GetPageBounds
GetPatternBits GetSheetLayerUserOrigin GetUnits GetUserOrigin
GetUserOriginFP InsertGradientSegment MarkCurrentDocChanged NumSelectedObjects
RGBToColorIndex RemoveGradientSegment ResetAllObjectsVisibility SelectAll
SetActiveSymbolDef SetClassVisibility SetCurrentLayer SetDashPat
SetGradientData SetGradientMidpointPosition SetGradientSpotColor SetGradientSpotPosition
SetHatchLevel SetLayerScaleN SetMarker SetProjection
SetRenderMode SetSheetLayerUserOrigin SetUserOrigin SetUserOriginFP
ShowCreateImageDialog ShowGradientEditorDialog ValidClass

Files and Directories

CreateTessellator DeleteTessellator FindFileInPluginFolderN ForEachFileInStandardFolder
ForEachFilePathInStandardFolder GetActiveDocumentN GetFilePathInStandardFolder GetFilePathInStandardFolderN
GetFilePathInUserRoot GetFilePathInUserRootN GetFolderN GetNamedSubFolderN
GetNumFilesInStandardFolder ImportDXF IsInStandardFolder IsInStandardFolderN
ReadMaterialImageFile TesselateObject WriteMaterialImageFile

Image Manipulation

UpdateThumbnailPreview

Internal use

CloseXCode OpenXCode

Memory Allocation

DisposeHandle DisposePtr GetHandleSize GetHandleState
HLock HUnlock NewHandle NewPtr
ReduceHandleSize SetHandleSize SetHandleState SetPtrSize

Menus

AddResourceToList BuildResourceList DeleteResourceFromList DisposeResourceList
GetActualNameFromResourceList GetMyMenuCommandIndex GetNameFromResourceList GetResourceFromList
ImportResourceToCurrentFile RegisterMenuForCallback ResourceListSize UnregisterMenuForCallback

Mode Bar

AddPullDownMenuItem AddPullDownMenuMode AddTxtBtnMode EnableMode
GetModeValue SetHelpString SetModeValue SetPullDownMenuSelection

Name Translation

ClassIDToName ClassNameToID InternalIndexToHandle InternalIndexToNameN
MaxClassID NameToInternalIndexN SetPolyVertexLoopDirection

Object Manipulation

AddToConstraintModel AddViewportAnnotationObject AppendParameterWidget AppendWidget
ConvertNurbsToPolylineArcs ConvertTo3DPolygons ConvertToNURBS ConvertToPolygon
ConvertToPolygonN ConvertToPolyline ConvertToUnstyledWall CreateConstraintModel
CreateOffsetNurbsObjectHandle CreateOffsetObjectHandle CustomObjectControlPtSet CustomObjectControlPtsCreate
CustomObjectControlPtsRemove CustomObjectGetSurfaceProxy CustomObjectReplacePath DeleteAllComponents
DeleteComponent DeleteConstraint DuplicateObject EnableParameter
EvaluateNurbsSurfacePointAndNormal ForEachLayer ForEachObject Get2DPt
GetBinaryConstraint GetClosestPt GetClosestSide GetComponentClass
GetComponentFill GetComponentFillColors GetComponentName GetComponentPenColors
GetComponentPenStyles GetComponentPenWeights GetComponentUseFillClassAttr GetComponentUsePenClassAttr
GetComponentWidth GetCustomObjectColor GetCustomObjectPath GetCustomObjectProfileGroup
GetCustomObjectSelectionGroup GetDimensionStandardVariable GetDistanceAlongNurbsCurve GetLocalizedPluginChoice
GetLocalizedPluginName GetLocalizedPluginParameter GetNumberOfComponents GetNurbsObjectDistanceFromPoint
GetObjectProperty GetObjectPropertyChar GetObjectVariable GetParameterOnNurbsCurve
GetPointAndParameterOnNurbsCurveAtGivenLength GetRoofEdge GetSingularConstraint GetViewportClassVisibility
GetViewportCropObject GetViewportGroup GetViewportGroupParent GetViewportLayerVisibility
GroupToMesh HasConstraint InsertAllParametersAsWidgets InsertNewComponent
InsertParameterWidget InsertWidget IsObjectFromReferencedFile IsViewportGroupContainedObject
MakePolyshapeValid MeshToGroup MoveObject MoveObject3D
NotifyLayerChange RemoveCustomObjectColor RemoveRoofEdge ResetObject
RotateObjectN ScaleObject3D ScaleObjectN SetBinaryConstraint
SetComponentClass SetComponentFill SetComponentFillColors SetComponentName
SetComponentPenColors SetComponentPenStyles SetComponentPenWeights SetComponentUseFillClassAttr
SetComponentUsePenClassAttr SetComponentWidth SetConstraintValue SetCustomDimensionStandardVariable
SetCustomObjectColor SetCustomObjectControlPointVisibility SetCustomObjectPath SetCustomObjectProfileGroup
SetCustomObjectSelectionGroup SetCustomObjectWallHoleGroup SetDefinition SetObjectProperty
SetObjectPropertyChar SetObjectVariable SetParameterVisibility SetRoofEdge
SetSingularConstraint SetViewportClassVisibility SetViewportCropObject SetViewportLayerVisibility
TrimToSelectedObjects UpdateConstraintModel UpdateViewport ViewportHasCropObject

Parametric Components

ClearComponentInstances FindFirstComponentInstance FindNextComponentInstance GetComponentInstanceName GetComponentInstanceTypeID IsEnabledComponentInstance AssignAsComponentInstance EnableComponentInstance

PDF

AcquireExportPDFSettingsAndLocation ClosePDFDocument ExportPDFPages OpenPDFDocument

Resources

GSCountResources GSGetApplicationResFile GSGetCurrentResFile GSGetIndResource
GSGetResource GSGetResourceName GSGetResourceString GSReleaseResource
GSRemoveResource GSSetResourceName GSUseResFile GSWriteResource

Selection Manipulation

FirstSelectedObject GetSelectionBounds GetSelectionBoundsCube MoveSelection
MoveSelection3D RotateSelectionN ScaleSelectionN

Text Block Objects

AddText AddTextFromBuffer CreateTextBlock DeleteText
GetCharNumFromPoint GetTextChars GetTextCharsToBuffer GetTextColor
GetTextFontIndex GetTextJustification GetTextLength GetTextLineHeight
GetTextOrientationN GetTextSize GetTextStyle GetTextVerticalAlignment
GetTextVerticalSpacing GetTextWidth GetTextWrap SetTextColor
SetTextFontIndex SetTextJustification SetTextOrientationN SetTextSize
SetTextStyle SetTextVerticalAlignment SetTextVerticalSpacing SetTextWidth
SetTextWrap SpellCheckTextBuffer

Textures

AttachDefaultTextureSpace CreateShaderRecord CreateTexture CreateTextureBitmap
CreateTextureBitmapFromPaintNode DeleteTextureSpace EditShaderRecord EditTexture
EditTextureBitmap EditTextureSpace GetClGenTexture GetClRoofTextures
GetClUseTexture GetClWallTextures GetShaderRecord GetTextureMappingInfo
GetTextureRef GetTextureSpace GetTextures GetVPClassGenTexture
GetVPClassRoofTextures GetVPClassWallTextures SetClGenTexture SetClRoofTextures
SetClUseTexture SetClWallTextures SetDefaultTextureMapping SetDefaultTextureSpace
SetTextureMappingInfo SetTextureRef

Tool Utilities

AddToolHighlightingObject AddToolHighlightingPoly AddToolHighlightingPoly3D AddToolHighlightingPoly3DAddVertex
AddToolHighlightingPolyAddVertex AddToolHighlightingPolyCreate AddToolHighlightingSegment AddToolHighlightingSegment3D
AddToolPersistentDraw AddToolSnapGeometry BoxToolDraw CallDefaultTool
ClearAllToolPts ClearDataDisplayBar ClickDragToolStatus CustomBarCreate
CustomBarGetFieldInfo CustomBarInstall CustomBarRelease CustomBarSetFieldAngle
CustomBarSetFieldInfo CustomBarSetFieldWorldCoord Default2DToolDraw Default3DToolDraw
DrawCoordArcN DrawCoordEllipse DrawCoordLine DrawCoordLine3D
DrawCoordRect DrawDataDisplayBar DrawNurbsObject DrawObject
EmptyToolHighlightingList GetCoords GetNumToolPts GetToolCoreInterface
GetToolPt2D GetToolPt3D GetToolPtCurrent2D GetToolPtCurrent3D
GetToolPtCurrentViewPt GetToolPtCurrentWorkingPlane GetToolPtViewPoint GetToolPtWorkingPlane
InstallConstraintAlong3DLine Interactive2DDraw OnePointToolStatus PolyToolStatus
PopLastToolPt RemoveHotSpot RemoveToolPersistentDraw RemoveToolSnapGeometry
RunTemporary2DTool RunTemporary3DTool SetCursorMode SetDataDisplayBarField
SetDimUserBarValue SetFloatUserBarValueN SetTextUserBarValue SetToolProperty
SetToolPropertyChar ThreePointToolStatus TrackHotSpot TrackTool
TwoPointToolStatus

Tree Walking & Manipulation

AddObjectToContainer AuxOwner DeleteObject FindHandleDeep
FirstMemberObj GetDefaultContainer GetDrawingHeader GetHatchListHeader
GetSymbolLibraryHeader InsertObjectAfter InsertObjectBefore LastMemberObj
NextObject ParentObject PrevObject SearchForAncestorType
SetPageBounds

Undo

AddAfterMoveObject AddAfterSwapObject AddBeforeMoveObject AddBeforeSwapObject
AddBothSwapObject AddCoordMoveObject2D AddCoordMoveObject3D EndUndoEvent
NameUndoEvent NonUndoableActionOK SetUndoMethod SupportUndoAndRemove
UndoAndRemove

Utility

AngleToStringN AssociateLinearDimension CStringCompare CStringEqual
CallPluginLibrary ClipSurface CombineIntoSurface DisableModules
DisplayContextHelpOfCurrentPlugin DisplayContextualHelp DisplayOrganizationDialog DoMenuName
DoProgramAction DoubleToString DrawScreen EllipseEllipseIntersect
ExportResource ExternalNameToID FontIndexFromName FontNameFromIndex
GetActiveSerialNumber GetCallBackInval GetCurrentMode GetDataBarCursorVisState
GetEnabledModules GetHostInfo GetModifierFlags GetProduct
GetSavedSetting HandlePendingUpdatesAndActivates HilitePalettesAndTopDocument IntersectObjects
Kludge LineEllipseIntersect LineLineIntersect ObjectNearCoordPt
OpenURL PlaySoundResource PointInsidePoly PointOnPolyEdge
RegisterExternal RegisterNotificationProcedure SetCallBackInval SetPersistentHighlight
SetSavedSetting StringToAngleN StringToDouble SymbolContainsLight
ToggleObjectHighlight UnfoldSurface UnregisterNotificationProcedure VerifyPluginLibrary

View Manipulation

GetPerspectiveInfo GetProjection GetRenderMode GetScreenDPI
GetViewCenter GetViewMatrix GetWorkingPlane NewCurrentViewMatrix
NewWorkingPlane PreviewDrawFrame PreviewFinish PreviewSetup
RedrawRect SetViewCenter SetViewMatrix SetWorkingPlaneAxis
SetWorkingPlaneVertex SetZoomFactorN ViewRotWorldZN WorldRect2ViewRect

Walls

AddBreak CreateWallFootPrint CreateWallHoleGroup DeleteBreak
ForEachBreak GetPolyBreakGeometry GetWallCaps GetWallCapsOffsets
GetWallCornerHeights GetWallHoleGroup JoinWalls MoveWallByOffset
ReverseWallSides SetAsPolyBreak SetBreak SetWallCaps
SetWallCapsOffsets SetWallCornerHeights SetWallStyle SetWallWidth
WrapGetWallWidth

Windows

GetScreenSize

Worksheets

AutoFitWorksheetRowHeights ClearWorksheetCells CreateWorksheet CreateWorksheetImage
DeleteWorksheetColumns DeleteWorksheetRows EnableDrawingWorksheetPalette GetTopVisibleWorksheet
GetWSCellAllBorders GetWkSheetSubrowCellActualString GetWorksheetAutoRecalcState GetWorksheetCellAlignment
GetWorksheetCellBorder GetWorksheetCellFill GetWorksheetCellFormula GetWorksheetCellNumberFormat
GetWorksheetCellString GetWorksheetCellTextAngle GetWorksheetCellTextColor GetWorksheetCellTextFormat
GetWorksheetCellValue GetWorksheetCellVertAlignment GetWorksheetCellWrapTextFlag GetWorksheetColumnOperators
GetWorksheetColumnWidth GetWorksheetFromImage GetWorksheetImage GetWorksheetMergedCellRange
GetWorksheetPlacement GetWorksheetRowColumnCount GetWorksheetRowHLockState GetWorksheetRowHeight
GetWorksheetSelection GetWorksheetSubrowCellString GetWorksheetSubrowCellValue GetWorksheetSubrowCount
GetWorksheetSubrowHeight InsertWorksheetColumns InsertWorksheetRows IsValidWorksheetCell
IsValidWorksheetRange IsValidWorksheetSubrowCell IsWorksheetCellNumber IsWorksheetCellString
IsWorksheetDatabaseRow IsWorksheetSubrowCellNumber IsWorksheetSubrowCellString IsWorksheetVisible
RecalculateWorksheet SetTopVisibleWorksheet SetWSCellAllBorders SetWSCellBottomBorder
SetWSCellInsideHorizBorder SetWSCellInsideVertBorder SetWSCellLeftBorder SetWSCellOutlineBorder
SetWSCellRightBorder SetWSCellTopBorder SetWorksheetAutoRecalcState SetWorksheetCellAlignment
SetWorksheetCellBorder SetWorksheetCellBorders SetWorksheetCellFill SetWorksheetCellFormula
SetWorksheetCellNumberFormat SetWorksheetCellTextAngle SetWorksheetCellTextColor SetWorksheetCellTextFormat
SetWorksheetCellVertAlignment SetWorksheetCellWrapTextFlag SetWorksheetColumnOperators SetWorksheetColumnWidth
SetWorksheetCurrentCell SetWorksheetPlacement SetWorksheetRowsHeight SetWorksheetSelection
ShowWorksheet ShowWorksheetDialog WorksheetMergeCells WorksheetSplitCells

Workspaces

CloseResFile GetCurrentWorkspaceFile OpenExternalResFile OpenWorkspaceResFile
SetWorkspaceFileToReload WSAddMenu WSAddMenuItem WSAddTool
WSAddToolPalette WSAddToolSet WSGetVersion WSMenuAddMenuItem
WSMenuBarAddMenu WSOpen WSPaletteGetHomeCorner WSPaletteSetHomeCorner
WSSetVersion WSToolPaletteAddToolSet WSToolSetAddTool WSToolSetAddToolChildToTool

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to ISDK interface:

typedef VCOMPtr<ISDK>  ISDKPtr;

Version

Available from: VectorWorks 2009

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]