VCOM:VectorWorks:IFCLib:IIFCSupport::IFC ReplaceDataWithMapping

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Replaces the IFC data attached to an object with the data from the active IFC data mapping.

VCOMError IFC_ReplaceDataWithMapping(
MCObjectHandle hObject,
TXString strObjName = "");

Parameters

hObject MCObjectHandle Handle to object.
strObjName TXString Object name. The default value for this parameter is empty string.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Please not that if the provided handle is NULL, then the IFC Data for all objects with object name strObjName is going to be replaced with the data from the active IFC data mapping. If the provided string is "allObjects" then the data for all objects in the file is going to be replaced with the data from the active IFC data mapping.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.