VCOM:VectorWorks:IFCLib:IIFCSupport::IFC IsFieldEmpty

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Checks whether there is mapping for the specified object's field.

virtual VCOMError VCOM_CALLTYPE IFC_IsFieldEmpty(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString IFC Entity name.
strFieldName TXString Field name.
strPSetName TXString Property Set name. Optional parameter used only when the field is a part of a Property Set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. The field is empty.
kVCOMError_False The function succeeded. The field is not empty.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.