VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPropertiesListOfPset

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport Returns the full list of properties of the Proserty Set (PSet). The function works with active IFC document.

VCOMError IFC_GetPropertiesListOfPset(
const TXString& strIfcPsetName,
TXStringArray& outArrProperties);

Parameters

strIfcPsetName TXString Property Set name.
outArrProperties TXStringArray Output parameter, the list of properties.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017