VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetNumPsets2

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport Returns the number of property sets (PSets), associated to the object. The number includes attached PSets and the PSets from IFC Data mapping.

VCOMError IFC_GetNumPsets2(
MCObjectHandle hObject,
bool bAllPsets,
short& outNumPsets);

Parameters

hObject MCObjectHandle Handle to the object.
bAllPsets bool TRUE for all PSets, including attached to the type instance. FALSE to skip attached to the type instance.
outNumPsets short Out parameter, the number of PSets.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Availare from: Vectorworks 2018

See Also

IFC_GetNumPsets

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_GetNumPsets|IFC_GetNumPsets]]