VCOM:VectorWorks:Filing:IXMLFile::ReadBuffer

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IXMLFile

Creates memory representation of XML content contained in the specified buffer. Then it can be analysed though IXMLFileNode instances.

Use IXMLFile::GetRootNode to get the XML root node.

virtual VCOMError VCOM_CALLTYPE ReadBuffer(
IXMLFileIOBuffer* pInputBuffer,
EXMLEncoding encoding) = 0;

Parameters

pInputBuffer IXMLFileIOBuffer* Memory buffer containing the XML.
encoding EXMLEncoding Encoding of the XML buffer suplied.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

The encoding supported by this interface are:

enum EXMLEncoding {
  eXMLEncoding_UTF8,
  eXMLEncoding_UTF16
};

The memory buffer provider has to implement the interface VCOM:VectorWorks:Filing:IXMLFileIOBuffer

See Also

VCOM:VectorWorks:Filing:IXMLFile::WriteBuffer | VCOM:VectorWorks:Filing:IXMLFileIOBuffer

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IXMLFile | VCOM:VectorWorks:Filing:IXMLFileNode

[[VCOM:VectorWorks:Filing:IXMLFile::WriteBuffer]] | [[VCOM:VectorWorks:Filing:IXMLFileIOBuffer]] [[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IXMLFile]] | [[VCOM:VectorWorks:Filing:IXMLFileNode]]