VCOM:VectorWorks:Filing:IXMLFile::CreateNew

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IXMLFile

Creates new XML file representation in the memory with the specified name.

In order to write that memory representation you have to use IXMLFile::WriteFile or IXMLFile::WriteBuffer

Use IXMLFile::GetRootNode to get the created XML root node.

virtual VCOMError VCOM_CALLTYPE CreateNew(
const TXString& rootName) = 0;

Parameters

rootName const TXString& The new file root name.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IXMLFile | VCOM:VectorWorks:Filing:IXMLFileNode

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IXMLFile]] | [[VCOM:VectorWorks:Filing:IXMLFileNode]]