VCOM:VectorWorks:Filing:IStdFile::WriteStringLine

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IStdFile

Write a sequence of characters into the current file read/write position of the file.

Then write the default line terminating symbols that are set by IStdFile::SetDefaultNewLine

virtual VCOMError VCOM_CALLTYPE WriteStringLine(
const TXString& line) = 0;

Parameters

line const TXString& The string that needs to be written to the file.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IStdFile

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IStdFile]]