VCOM:VectorWorks:Filing:IStdFile::Write

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IStdFile

Write bytes to the file. The bytes are written in the current file read/write position.

The current file read/write position is updated after writting is successful.

virtual VCOMError VCOM_CALLTYPE Write(
Uint64 bytes,
const void* pBuffer) = 0;
virtual VCOMError VCOM_CALLTYPE Write(
Sint64 value) = 0;
virtual VCOMError VCOM_CALLTYPE Write(
Uint64 value) = 0;
virtual VCOMError VCOM_CALLTYPE Write(
Sint32 value) = 0;
virtual VCOMError VCOM_CALLTYPE Write(
Uint32 value) = 0;
virtual VCOMError VCOM_CALLTYPE Write(
Sint16 value) = 0;
virtual VCOMError VCOM_CALLTYPE Write(
Uint16 value) = 0;
virtual VCOMError VCOM_CALLTYPE Write(
Sint8 value) = 0;
virtual VCOMError VCOM_CALLTYPE Write(
Uint8 value) = 0;
virtual VCOMError VCOM_CALLTYPE Write(
const TXString& value,
bool bIncludeZero) = 0;

Parameters

bytes Uint64 Number of bytes that is to be written in the file from 'pBuffer' parameter.
pBuffer const void* The buffer suplying bytes to be writted into the file. 'bytes' parameter contains the number of bytes to be written.
value Sint64 Write signed 64 bit number to the file.
value Uint64 Write unsigned 64 bit number to the file.
value Sint32 Write signed 32 bit number to the file.
value Uint32 Write unsigned 32 bit number to the file.
value Sint16 Write signed 16 bit number to the file.
value Uint16 Write unsigned 16 bit number to the file.
value Sint8 Write signed 8 bit number to the file.
value Uint8 Write unsigned 8 bit number to the file.
value const TXString& Write sequence of characters of a string into the file. 'bIncludeZero' parameter determines if it should write 0x00 after the character sequence or not.
bIncludeZero bool Determines if it should write 0x00 after the character sequence or not when writeing 'value' string parameter.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IStdFile

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IStdFile]]