VCOM:VectorWorks:Filing:IStdFile::ReadStringLine

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IStdFile

Read a line of characters from the file current read/write position.

The line is terminated from 0x0A or 0x0D or 0x0A0D or 0x0D0A characters.

virtual VCOMError VCOM_CALLTYPE ReadStringLine(
TXString& outLine) = 0;

Parameters

outLine TXString& Output parameter. Return the string that has been read from the file.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IStdFile

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IStdFile]]