VCOM:VectorWorks:Filing:IStdFile::Read

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IStdFile

Read different amount of bytes from the current file read/write position.

After reading the current file read/write position is moved forward (toward the end of the file) with the amount of bytes read.

virtual VCOMError VCOM_CALLTYPE Read(
Uint64& inoutBytes,
void* pBuffer) = 0;
virtual VCOMError VCOM_CALLTYPE Read(
Sint64& outValue) = 0;
virtual VCOMError VCOM_CALLTYPE Read(
Uint64& outValue) = 0;
virtual VCOMError VCOM_CALLTYPE Read(
Sint32& outValue) = 0;
virtual VCOMError VCOM_CALLTYPE Read(
Uint32& outValue) = 0;
virtual VCOMError VCOM_CALLTYPE Read(
Sint16& outValue) = 0;
virtual VCOMError VCOM_CALLTYPE Read(
Uint16& outValue) = 0;
virtual VCOMError VCOM_CALLTYPE Read(
Sint8& outValue) = 0;
virtual VCOMError VCOM_CALLTYPE Read(
Uint8& outValue) = 0;
virtual VCOMError VCOM_CALLTYPE Read(
TXString& outValue) = 0;
virtual VCOMError VCOM_CALLTYPE Read(
TXString& outValue,
size_t len) = 0;

Parameters

inoutBytes Uint64& In out parameter. Number of bytes that needs to be read from the file into 'pBuffer' parameter. Returns number of bytes actually read.
pBuffer void* Buffer for data to be read. 'inoutBytes' contains the bytes that needs to be read from the file.
outValue Sint64& Signed 64 bit number to be read from the file.
outValue Uint64& Unsigned 64 bit number to be read from the file.
outValue Sint32& Signed 32 bit number to be read from the file.
outValue Uint32& Unsigned 32 bit number to be read from the file.
outValue Sint16& Signed 16 bit number to be read from the file.
outValue Uint16& Unsigned 16 bit number to be read from the file.
outValue Sint8& Signed 8 bit number to be read from the file.
outValue Uint8& Unsigned 8 bit number to be read from the file.
outValue TXString& Reads a string from the file. The string is terminated by the first encountered 0x00 character.
len size_t Determine the amount of characters that will be read to form the string when reading strings.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IStdFile

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IStdFile]]