VCOM:VectorWorks:Filing:IFolderIdentifier::DuplicateOnDisk

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFolderIdentifier

Duplicates this folder into specified folder location.

virtual VCOMError VCOM_CALLTYPE DuplicateOnDisk(
IFolderIdentifier* newFolder,
bool overrideIfNecessary = false,
TXString* displayProgressDialog = NULL) = 0;

Parameters

<line> newFolder IFolderIdentifier* New folder that will contain the copy of this folder.

overrideIfNecessary bool Optional. Default: false; If false the call will fail if the folder exist; true will cause the existing folder to be deleted and the copy will be placed in the distination folder.

</lineList>

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_FileNotFound This folder is not found.
kVCOMError_BadPathSpecified This folder has bad path specified.
kVCOMError_Failed The copy faild.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier

[[VCOM:VectorWorks:Filing:IFolderIdentifier]]