VCOM:VectorWorks:Filing:IFileIdentifier::GetFolder

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileIdentifier

Obtain IFolderIdentifier instance in which this file exist.

virtual VCOMError VCOM_CALLTYPE GetFolder(
IFolderIdentifier** ppOutParentFolderID) = 0;

Parameters

ppOutParentFolderID IFolderIdentifier** Output parameter. Return the folder instance of the folder where the file is.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]