VCOM:VectorWorks:Filing:IFileChooserDialog::GetSelectedFileName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IFileChooserDialog

Return file identifier of the specified index of selected file after dialog has closed.

virtual VCOMError VCOM_CALLTYPE GetSelectedFileName(
Uint32 fileIndex,
IFileIdentifier** ppOutFileID) = 0;

Parameters

fileIndex Uint32 File index which has to be returned.
ppOutFileID IFileIdentifier** Output parameter. The returned file identifier instance.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IFileChooserDialog

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IFileChooserDialog]]