VCOM:VectorWorks:Filing:IApplicationFolders::GetFilePathInUserRoot

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IApplicationFolders

Get the filename in the given folder class under the User Data root.

This function is useful for obtaining the paths of files to save out to.

virtual	VCOMError VCOM_CALLTYPE GetFilePathInUserRoot(
EFolderSpecifier folderClass,
const TXString& fileName,
IFileIdentifier** ppOutFileID) = 0;

Parameters

folderClass EFolderSpecifier One of the folder type constants defined in FolderSpecifiers.h
fileName const TXString& The name of the file
ppOutFileID IFileIdentifier** Output parameter. Returns the file under the User Data root.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IApplicationFolders

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IApplicationFolders]]