VCOM:VectorWorks:Filing:IApplicationFolders::GetFilePathInStandardFolder

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IApplicationFolders

Gets the first file in the search path with the given name.

If the file is not found, the path will be under the User Data folder, ready to be created.

virtual VCOMError VCOM_CALLTYPE GetFilePathInStandardFolder(
EFolderSpecifier folderSpec,
const TXString& fileName,
IFileIdentifier** ppOutFileID) = 0;

Parameters

folderSpec EFolderSpecifier One of the folderSpecifier constants defined in FolderSpecifiers.h
fileName const TXString& the name of the file to search for.
ppOutFileID IFileIdentifier** Output parameter. The file that has been found.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IApplicationFolders

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IApplicationFolders]]