VCOM:VectorWorks:Filing:IApplicationFolders::ForEachFileInStandardFolder

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IApplicationFolders

For each file in the folder class, calls a given function pointer. The files are returned in alphabetical order, regardless of their location on the filesystem. If a file with the same name occur more than once in the search path, only the first occurrence will be returned. Each file passed into the callback is guaranteed to exist at that time, so its existence may not need to be rechecked.

virtual VCOMError VCOM_CALLTYPE ForEachFileInStandardFolder(
IFolderContentListener* pVisitor,
EFolderSpecifier folderSpec) = 0;

Parameters

pListener IFolderContentListener* A listener object whose member OnFileContent will be called with each existing, uniquely-named file. See IFolderIdentifier::EnumerateContents
folderSpec EFolderSpecifier The folder class to obtain files from.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IApplicationFolders

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IApplicationFolders]]