VCOM:VectorWorks:Filing:IApplicationFolders::FindFileInStandardFolder

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IApplicationFolders

Finds the first file in the search path with the given name. If the file is not found, outFileID will refer to the filename under the [User] root, ready to be created.

virtual VCOMError VCOM_CALLTYPE FindFileInStandardFolder(
EFolderSpecifier folderSpec,
const TXString& fileName,
IFileIdentifier** outFileID) = 0;
virtual VCOMError VCOM_CALLTYPE FindFileInStandardFolder(
EFolderSpecifier folderSpec,
const TXString& fileName,
const TXString& extension,
IFileIdentifier** outFileID) = 0;

Parameters

folderSpec EFolderSpecifier The folder class to search in.
fileName const TXString& The filename to search for. The filename must not include a path of any kind.
extension const TXString& (optional) The file extension to tack onto fileName
outFileID IFileIdentifier** Output parameter. The first file matching the filename in the search path

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IApplicationFolders

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IApplicationFolders]]