VCOM:VectorWorks:Filing:IApplicationFolders::FindFileInPluginFolder

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IApplicationFolders

Searches for a file in all plug-in folders.

If fileName has no file extension, it is assumed to be the base name of a plug-in, and the function will search for files with that base name and extensions of 'vsm', 'vst', 'vso', 'vlb', 'dll', 'sdo', and 'qtr'.

virtual VCOMError VCOM_CALLTYPE FindFileInPluginFolder(
const TXString& fileName,
IFileIdentifier** ppOutFileID) = 0;

Parameters

fileName const TXString& The name of the file to search.
ppOutFileID IFileIdentifier** Output parameter. Returns the file identifier if the file is found.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IApplicationFolders

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IApplicationFolders]]