SDK:Object Variables

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Object variables are constants that are used to set values to SDK:MCObjectHandle referring to a VectorWorks object.

The constants are used with functions:

Variables List

ovHideDetail

Boolean value determining if the object is marked as hide details object. See SDK:Parametric Hide Details.

gSDK->SetObjectVariable( hLine, ovHideDetail, TVariableBlock( (Boolean) true ));

ovHideNonDetail

Boolean value determining if the object is marked as non-hide details object. See SDK:Parametric Hide Details.

gSDK->SetObjectVariable( hLine, ovHideNonDetail, TVariableBlock( (Boolean) true ));

See Also