SDK:Layout Manager User Interface

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..SDK:Using the SDK|Using the SDK ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Introduction

Vectorworks uses Layout Manager to provide dialog system that creates the similar dialogs on Windows and Mac with the same code.

It highly recommended all plug-ins to use it so they could be portable.

Working with dialogs is comprised of two parts:

1. Creating the layout -- use Layout Manager API calls to create the controls and position them on the dialog. The layout manager user relations to position the controls e.g. this control is underneath the other, or this control is on the right of the other.

2. Handling the layout -- this is code that manages the behavior of the dialog. Layout Manager APIs are used to access the controls. This is typically a class inherited from VWFC::VWUI::VWDialog that provides a way to capture events and DDX (Dynamic Data Exchange) mechanism to handle control data.

Creating Dialog Layouts

The easiest way to create a dialog layout is to use the SDK:Dialog Builder tool. It is a plug-in for Vectorworks that uses Parametric Objects to identify controls and handles to relate them. Then it produces VectorScript or Python script that generates the dialog layout.

Also some SDK:Dialog Builder Samples are available.

Handling a Dialog

Other topics:

Layout Control Specifics