SDK:IWidgetsProvider::GetWidgetAt

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

Member of SDK:IWidgetsProvider

Return the widget at the specified index.

virtual SWidgetDefinition& GetWidgetAt(
size_t index) = 0;

Parameters

index size_t Index to the widget that is to be returned.

Return Value

Returns a reference to SDK:SWidgetDefinition for the representation of the widget. You can modify this widget by modifying the reference.

Note that this reference may change when the object is regenerated (for example VectorScript with 'compile on each call' is on will cause init of the widgets on each reset).

Never pass this reference to functions, use it locally. But you can make a copy of it for further use if needed.