SDK:IWidgetData

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

Provides base data for SDK:SWidgetDefinition widget.

Used in SDK:Parametric Custom Shape Pane support.

Interface

//----------------------------------------------------------
class IWidgetData
{
public:
  virtual const TXString& GetData() const = 0;
  virtual void            SetData(const TXString& data) = 0;
};

Members

GetData Returns the data contained by this interface.
SetData Set data into this interface.

Remarks

Regardles of the type of the widget (see EWidgetType) the data contained by this interface is always string.

The user must convert the string to proper type when needed.

Version

Available from: VectorWorks 2009

See Also

SDK:SWidgetDefinition | VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider | VCOM:VectorWorks:PluginSupport:IExtendedProps

[[SDK:SWidgetDefinition]] | [[VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider]] | [[VCOM:VectorWorks:PluginSupport:IExtendedProps]]